OpenShot: Probleme mit AVCHD Lite

Hachja. Nun wollte ich gestern »mal eben schnell« ein kurzes Video für die Großeltern zusammenklicken, welches deren Enkelin auf einer Schulaufführung zeigt — während der moderne Erwerbstätige ja flexibel zu sein hat, stellen mit zunehmendem Alter 300+ km Entfernung, zumal ohne adäquate Bahnanbindung, doch einen Hinderungsgrund dar, mal eben vorbeizukommen. Nunja, wozu gibt es DSL und/oder DVD, und schließlich rockt – für ein freies und kostenloses Tool – OpenShot ja die Hütte …
Nun, ich muß mein Urteil revidieren/konkretisieren: generell ist OpenShot ein feines Stück Software, unrund an vielen Ecken noch, aber imho auf dem richtigen Weg und weiter als vieles andere, was ich in dem Bereich gesehen habe. (Daß man chroma keying nicht auf einen Bereich beschränken kann, stört wahrscheinlich echt nur Leute wie mich, die keine Studioaufnahmen machen …)
Allerdings kotzt, Verzeihung, OpenShot 1.1.0 auf Ubuntu 9.10 ganz massiv ins Essen, wenn es MTS- (MPEG Transport Stream) Dateien meiner Panasonic TZ7 (AVCHD Lite, 1280x720p50, H.264-Video mit AC3-Audio) verarbeiten soll. Stimmt die Synchronität von Audio und Video bei komplett verwendeten Dateien noch meistens, ist ein Ton-Bild-Versatz beim Schnitt die Regel, die gelegentlich trotz Schnitt in OpenShot synchron bleibende Schnipsel bestätigen :(
Notgedrungen reencode ich die MTS-Dateien nach AVI — ja, leider reencode (ffmpeg -i $basename.MTS -vcodec libx264 -vpre hq -b 15M -bt 1M -threads 0 $basename.mp4), da ein simpleres Umpacken (mencoder $basename.MTS -ovc copy -oac copy -o $basename.avi) zwar von mplayer noch abgespielt wird inkl. Video, in OpenShot aber nur noch ein ziemliches fettes Audio-File ist. Any hint appreciated …
Warum das? Nun, mit den Mitteln von OpenShot – Bildschirm und Kopfhöhrer – Synchronität wiederherzustellen grenzt an eine Sisyphus-Aufgabe, zumal bei schlecht erkennbaren Lippenbewegungen. Da ist selbst das Reencode von x264 nach x264 mit 2 Frames pro Sekunde besser investierte Zeit …
Insofern möchte ich auch @_refugee_ nahelegen, beim angekündigten Test auf die unterschiedlichen Eingangsformate und deren Bearbeitbarkeit mit OpenShot ein Auge zu haben. (In meinem, final 20 Minuten langen, Zusammenschnitt gab es rd. einmal je halber Stunde Bearbeitungszeit einen Crash von OpenShot; ganz offensichtlich macht das Handling von x264-Streams zumindest in MTS-Containern noch massiv Probleme :( Ah, und apropros: OpenShot kennt kein Autosave; wer also MTS-Container beackert tut gut daran, häufiger seinen Bearbeitungsstand selbst zu speichen. Und keine Bange, wenn nach einem Crash & Reload des Projektes der Positionszeiger nicht mehr sich mitbewegt: einfach ‘n Schnipsel hinten anhängen, danach tat’s zumindest bei mir wieder …)

2 thoughts on “OpenShot: Probleme mit AVCHD Lite

  1. Wir wandeln die Clips aus den Pocket-HD-Cams, V-DSLRs und nativen HD-Cams auch immer vorher mit MPEG Streamclip bevor wir es in Final Cut verwursten. Das bläht die Clips zwar tüchtig auf, aber ermöglicht die beste Verarbeitung.
    Scheint aber auch allgemein gängige Praxis bei den professionellen Video-Filmern zu sein. Auch so Cracks wie Philip Bloom empfehlen es.
    Was ist denn das bekömmlichste Format für OpenShot? Gibt es Empfehlungen seitens des Autors?

  2. Hmm, was bedeutet »Das bläht die Clips zwar tüchtig auf«? Ich transcodiere zwangsläufig das Material (von h.264 nach h.264) mit lächerlich hohen Bitraten (15+ MBit/sec), um den Verlust gering zu halten — ziemlich hirnrissig, da ein »simples« Remuxen ja reichen würde, leider kenne ich kein Remux-Tool (für Linux) für MPEG4-Datenströme.

    Was ist denn das bekömmlichste Format für OpenShot? Gibt es Empfehlungen seitens des Autors?

     
    Die Aussage ist »Support for many video, audio, and image formats (based on FFmpeg)«; naja, und mit MTS, was schein’s nicht wirklich ein bild-ton-synchrones Format zu sein scheint, hat ffmpeg leider gelegentlich so seine Probleme :( Konsequenterweise ist ein nach AVI gewandelter Clip ebenfalls asynchron; Kunststück, ist ffmpeg ja auch auf der Kommandozeile das Tool der Wahl :( Allerdings bleibt quasi nur die Wahl zwischen Pest und Cholera: der MJPEG-Modus der TZ7 schreibt »nur« 25p raus, im AVCHD-lite-Modus sind’s 50p. Für die Weiterberabeitung möchte man also schon eher 50p; in dem Zusammenhang finde ich es dann auch ziemliche unschön, daß z. B. die Kodak Zi8 nur »60« (in Wirklichkeit: »NTSC*2«, also 59,94 fps) oder 29,97 fps ausgibt => für den europäischen Markt erwarte ich eigentlich schon zumindest 50p, denn an dieser regionalen Unterscheidung hat sich ja komischerweise auch bei HDTV nichts geändert.
    So schön HD ja aussieht: sobald es an’s Neuberechnen geht, vergeht mir der Spaß – mein »Intel(R) Pentium(R) Dual CPU T3400 @ 2.16GHz« hat dafür jedenfalls nicht genug Dampf für. Ich werde mal sehen, ob ich auf den VMware-Sklaven mit seinem »AMD Phenom(tm) 9650 Quad-Core Processor« mehr werde; den eigentlichen Video-Server mit »AMD Athlon(tm) 7750 Dual-Core Processor« muß ich erstmal neu installieren, bevor da OpenShot (und die ganzen Codecs dafür) drauf rennt :(

Comments are closed.