VDSL mit congstar und Fritzbox

Es hat eine Woche gedauert, aber nun funktioniert mein VDSL-Anschluß auch mit meiner Fritzbox 7570 (in Speedport W920V-Verkleidung).

Bandbreite satt, nun auch mit »congstar«-Einstellung ...

Ich hatte es ja hinbekommen, daß mit Speedport W920V-Firmware der PPPoE-Login klappte — VoIP allerdings tat nicht. Vor dem Verlassen Berlins zum Wochenende hatte ich dann doch noch wieder auf eine speed-to-fritz-Firmware umgestellt, diesmal basierend auf der letzten 7570er mit den Features der letzten 4er für die 7270v2 (technisch ist die 7570 bzw. der Vorgänger Speedport W920V eine frühe 7270 plus VDSL2/ADSL2- statt nur ADSL2-Modem; AVM hat aber leider den Support nie ernst genommen und zum Jahresanfang 2012 auch offiziell eingestellt). Anders als die vorangehenden Versuche mit einer auf der Speedport-FW basierenden FW lief diese ganz gut (keine offensichtlichen Fehler wie wirre Sonderzeichen in den Logfileeinträgen) und syncte tapfer auf VDSL, congsters PPPoE-Server aber waren außer Reichweite.

Am Wochenende hatte ich dann etwas Zeit zumn googlen, und siehe, ein noch recht junger Thread im congster-Forum hatte die Lösung:

kurz zusammengefasst FritzBox –> Internet –> Zugangsdaten –> Internetanbieter: Vodafone/Arcor ADSL und VDSL –> benutzername: vdsl/xxx@congstar.de

Und ja, mit diesen Einstellungen war sowohl ein PPPoE-Login bei congstar möglich als auch die Verbindung der neuen, per VoIP realisierten Telefonnummern.

Natürlich lies mich das jetzt nicht ruhen, insbesondere nach dem Kommentar zu »Impact«, der auf Unterschiede in der ar7.cfg hinwies. Ergo habe ich einen diff der beiden Konfigurationen gemacht, und nun ist mir auch klarer, was da abgeht ;)

Es ist nicht, wie ich erst dachte, ein VLAN-Tagging-Thema, zumindest nicht nur. Vielmehr geht die Einstellung »congstar« offensichtlich davon aus, daß nur ADSL2/eigenes VDSL vorhanden ist (»vdsl_resalearch = no;«), sodaß für VoIP auch ein zweiter virtueller ATM-Kanal vorgesehen wird — den es hier nicht gibt (weshalb die SP-Firmware wohl auch kein VoIP hinbekam). Die Unterschiede im Einzelnen:

--- ar7.cfg-arcor 2012-10-30 23:28:54.000000000 +0100
+++ ar7.cfg-congstar 2012-10-30 23:35:06.000000000 +0100
@@ -16 +16 @@
- * Tue Oct 30 23:26:13 2012
+ * Tue Oct 30 23:33:33 2012
@@ -21 +21 @@
- active_provider = "arcor";
+ active_provider = "congstar";
@@ -29 +29 @@
- vdsl_resalearch = yes;
+ vdsl_resalearch = no;
@@ -212 +197,13 @@
- connections = "internet", "voip";
+ connections = "internet";
+ } {
+ VPI = 1;
+ VCI = 35;
+ traffic_class = atm_traffic_class_UBR;
+ pcr = 0;
+ scr = 0;
+ priority = 1;
+ dsl_encap = dslencap_pppoe;
+ ipbridgeing = no;
+ ipbridgeing_igmp = no;
+ pppoeforwarding = no;
+ connections = "voip";
@@ -285 +282 @@
- dsl_encap = dslencap_inherit;
+ dsl_encap = dslencap_pppoe;
@@ -293 +290 @@
- use_dhcp = yes;
+ use_dhcp = no;

Nach Eingriffen in die ar7.cfg geht's auch mit congstar VDSL ...

Kleine, aber feine Änderungen. Ein etwas unschöner Effekt, der aber an der fritzsierten Firmware liegen kann: die VoIP-Zugänge muß ich als »anderer Anbieter« anlegen, das UI zeigt sie mir dann aber als »congstar« an (und mit nur den Angaben bei »congstar« laufen sie nicht). Insofern würde ich sagen, auch wenn, mit Aufwänden (lies: ar7.cgf-Änderungen) ein korrektes Labelling des Anschlusses als »congstar« möglich ist, die Einstellung »Arcor/Vodafone« ist deutlich einfacher und, zumindest auf gemoddeten 7570er, wohl auf lange Sicht auch streßfreier.

P.S.: Geht’s nur mir so, daß ich (immer noch) »congster« statt »congstar« schreibe?